Nejde mi nastavit CKeditor ani IMCE

Pořád se patlám s testovací verzí webu na Drupalu (8.6.7) a dnes jsem zjistil, že nemohu nastavit CKEditor - potřeboval jsem povolit nahrávání souborů. Když kliknu na nastavení vidím jenom prázdnou stránku. Zkusil jsem nainstalovat IMCE a v nastavení když na něj kliknu, tak vidím taky jen prázdnou stránku.

Je to tak asi od začátku, ale doteď jsem to nepotřeboval. Můžete mě někam nasměrovat?
Díky.

návštěvník

Ještě pro pořádek uvedu, že v editaci článku to normálně funguje. Přepínám formát textu mezi Basi a Full HTML, vše OK. Jenom nic nenastavím...

návštěvník

Jo a ještě poznatek - když chci přidat nový formát textu a vyberu CKeditor a chci formát uložit, napíše mi to:

"Vybraný editor textu je třeba nakonfigurovat."

návštěvník

Ještě jeden poznatek. Když to udělám v jiném prohlížeči, dostanu chybu
"HTTP ERROR 500"
Jak u IMCE, tak u CKEditoru. Teď to teda hledám, ale nevím, jestli se něčeho dopátrám.

Profile picture for user Jan Polzer

HTTP ERROR 500 je chyba na serveru. Je něco podrobnějšího psáno v Logy > Poslední zprávy v logu? Případně v error logu na serveru?

Není třeba problém ve staré verzi PHP?

návštěvník

Verze php je 5.6.39

V logu bylo toto a to jsem nastavil:

Bezpečnostní varování: Nelze zapisovat do souboru .htaccess. Vytvořte prosím soubor .htaccess v adresáři private://, který bude obsahovat následující řádky:

# Deny all requests from Apache 2.4+.

Require all denied

# Deny all requests from Apache 2.0-2.2.

Deny from all

# Turn off all options we don't need.
Options -Indexes -ExecCGI -Includes -MultiViews

# Set the catch-all handler to prevent scripts from being executed.
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2006_006

# Override the handler again if we're run later in the evaluation list.
SetHandler Drupal_Security_Do_Not_Remove_See_SA_2013_003

# If we know how to do it safely, disable the PHP engine entirely.

php_flag engine off

a toto:
"Warning: file_exists(): Unable to find the wrapper "private" - did you forget to enable it when you configured PHP? ve funkci system_requirements() (řádek 512 souboru /usr/httpuser/zsoskol/www/drupal/core/modules/system/system.install) #0 ..." to je dlouhý výpis, zkopíroval jsem začátek

Profile picture for user Jan Polzer

To je podle mě starou verzí PHP. 5.6 není již dlouho podporovaná, Drupal 8 ji taky opustil. Nepamatuju si přesně, jak je to s Drupalem 8.6, jestli na tom ještě neměl teoreticky fungovat, ale viděl bych to jako nejpravděpodobnější problém.

Odpovědět

Obsah tohoto pole je soukromý a nebude veřejně zobrazen.

Filtered HTML

  • Povolené HTML značky: <a href hreflang> <em> <strong> <cite> <code> <ul type> <ol start type> <li> <dl> <dt> <dd> <p> <br>
  • Řádky a odstavce se zalomí automaticky.
  • Web page addresses and email addresses turn into links automatically.

Odesláním komentáře souhlasíte s podmínkami Ochrany osobních údajů

reklama
Sledujte Maxiorla na Facebooku

Maxiorel na Facebooku

Poslední komentáře
reklama
Nové diskuze
reklama
Hosting pro Drupal a WordPress

Hledáte český webhosting vhodný nejenom pro redakční systém Drupal? Tak vyzkoušejte Webhosting C4 za 1200 Kč na rok s doménou v ceně, 20 GB prostoru a automatické navyšováním o 2 GB každý rok. Podrobnosti zde.

Knihy o Drupalu

Kniha Drupal 8 Kniha Drupal 7 333 tipů a triků pro Drupal
Více na KnihyPolzer.cz

@maxiorel na Twitteru

Maxiorel na Twitteru