5x zranitelnost modulů pro Drupal

Včera se objevilo celkem pět nových hlášení o možných slabinách rozšiřujících modulů pro redakční systém Drupal. Když mi došlo na e-mail první varování, něco mi říkalo, že nezůstane pouze u něj. Co tedy komu hrozí?

Reklama

Jako nekritická je označena zranitelnost modulu Pblog. Problém se týká SQL injektáže ve verzi modulu, která je již více než tři roky stará. Žádné opravy nejsou k dispozici, neboť novější verze tento problém nemají.

Vysoce kritická zranitelnost trápí modul Magic Tabs sloužící k implementaci záložek pomocí AJAXu. Pomocí upravené URL lze spustit škodlivé PHP skripty. Oprava je k dispozici jako Magic Tabs 5.x-1.1.

Méně kritickou zranitelnost najdete v modulu Taxonomy Image, který u článků zobrazuje obrázky podle kategorie, do které článek patří. Zranitelností je známé XSS. Opravy jsou k dispozici jako Taxonomy Image 5.x-1.3 a Taxonomy Image 6.x-1.3.

Méně kritická zranitelnost byla objevena také v modulu Node Hierarchy, který má špatně implementována přístupová práva. Opravy jsou k dispozici jako Node Hierarchy 5.x-1.1 a Node Hierarchy 6.x-1.0.

Poslední ze včera nahlášených problémů se týká vysoce kritické zranitelnosti v modulu Aggregation. Jde o kombinaci XSS, SQL injektáže, vzdáleného spouštění kódu a překonání přístupových oprávnění. Pokud tento modul používáte, měli byste bezodkladně instalovat nejnovější verzi Aggregation 5.x-4.4.

Tagy: 

Reklama

Přidat komentář